Production Release Maintenance
Scheduled for Jan 26, 16:00 - 19:00 PST
Update
We will be undergoing scheduled maintenance during this time.
Posted Jan 08, 2021 - 09:52 PST
Scheduled
Philanthropy Cloud will have a scheduled release window beginning at approximately 4PM Pacific Time and ending at approximately 7PM Pacific Time. We will be upgrading Philanthropy Cloud to the latest release version. During this period, Philanthropy Cloud applications and API services may not be available.
Posted Jan 26, 2021 - 11:07 PST
This scheduled maintenance affects: Production.