Demo System -- currency conversion service disruption
Incident Report for Salesforce.org Philanthropy Cloud
Resolved
This incident has been resolved.
Posted Mar 19, 2021 - 23:17 PDT
Investigating
We are currently experiencing errors with our currency conversion service, affecting some donors who attempt to make donations in a currency other than the primary currency of their workplace.
Posted Mar 19, 2021 - 22:02 PDT
This incident affected: Demo.